W.I.P. Riggswater

Discussion in 'Tracks' started by MGMetroDave, Oct 12, 2019.

  1. luchian

    luchian Administrator Staff Member Pilot RLR

    Joined:
    Jun 3, 2014
    Messages:
    2,888
    Likes Received:
    1,385
    :lol: so creative, I love it !
     
    MGMetroDave likes this.
  2. ChunkiEgg

    ChunkiEgg New Member

    Joined:
    May 18, 2019
    Messages:
    18
    Likes Received:
    23
    Location:
    Hampshire, UK
    Looking awesome Dave, could actually feel my sphincter tightening as you were heading to the brow of the hills in this :lol:. Nice touch with the birds swooping down too and the ambient sound effect, lots of nice details in there!

    Can really imagine this being a rally stage with spectators lining the sides of the road with cars parked up on the verges, it reminds me somewhat of the moor roads around West Yorks/Halifax when I lived up between Leeds and Bradford :) Really wish I had driven my RS2000 (The mk6 model, not the classic mk2 :D ) around those roads more!

    Can see a lot of love is going in to this :) Looking forward to seeing updates of this track!
     
    Prototype, MLT and MGMetroDave like this.
  3. MGMetroDave

    MGMetroDave Active Member

    Joined:
    Apr 7, 2019
    Messages:
    141
    Likes Received:
    155
    Thanks for your comments @ChunkiEgg ! :lol: I guess that's a positive reaction :ROFLMAO:
    Oh good, I'm glad it feels like it's somewhere up north. That's the feel I was aiming for. I love that part of the country. Nothing wrong with a mk 6 RS2000 either! I really liked that era of escort. I think each mk/iteration had its own charm. They were rallied quite a lot if I recall? I'm sure I've got a mk 5 or 6 AC car mod installed. I'll have to use it for the next screenshots.
    Hopefully I'll be able to include a rally stage for this track at some point too. It's got several off-road dirt tracks that could work.
     
    Last edited: Nov 9, 2019
    MLT likes this.
  4. ChunkiEgg

    ChunkiEgg New Member

    Joined:
    May 18, 2019
    Messages:
    18
    Likes Received:
    23
    Location:
    Hampshire, UK
    Haha Yep definitely a compliment mate :)

    I live back on the South Coast, and the scenery isn't as dramatic, that's for sure but has it's own charms- A272 between Petersfield was always fun in the 2k and the ST170 and the A285 between Chichester and Guildford is a good laugh too, may have to look in to doing a point to point race based on these roads in future :)

    I prefer the mk5 Escort shape if it's unmolested although the cossie front grille does smarten it up more, but the Rally spec Maxi F2 kit on a mk6 (google
    Gwyndaf Evans, Max Power Project 2000, mattman RS2000, or Minirotty Lucifer 2 for some automotive porn)... I make a mess every time I see one!
     
    MGMetroDave likes this.
  5. MGMetroDave

    MGMetroDave Active Member

    Joined:
    Apr 7, 2019
    Messages:
    141
    Likes Received:
    155
    The windmill needs more work, but it's working. stFlow on the windmill and cyclist

    [​IMG]

    [​IMG]

    [​IMG]
     
    EKO Sim-Racing, luchian and ChunkiEgg like this.
  6. ChunkiEgg

    ChunkiEgg New Member

    Joined:
    May 18, 2019
    Messages:
    18
    Likes Received:
    23
    Location:
    Hampshire, UK
    looking good Dave :) loving the second image, having a bit of a mishap with the Cossie by any chance? :D
     
    MGMetroDave likes this.
  7. MGMetroDave

    MGMetroDave Active Member

    Joined:
    Apr 7, 2019
    Messages:
    141
    Likes Received:
    155
    Couldn't resist sorry! :ROFLMAO:
     
    ChunkiEgg likes this.
  8. MGMetroDave

    MGMetroDave Active Member

    Joined:
    Apr 7, 2019
    Messages:
    141
    Likes Received:
    155
    Sorry, weird thing, but has anyone else noticed specularity disappear from AC since Shaders Patch 0.1.25-preview245? Bridgehampton as an example here, but same's happening on my track.

    Just checking with you here to make sure I'm not going crazy before I submit it as a bug. 1.jpg 2.jpg 3.jpg
     
  9. MGMetroDave

    MGMetroDave Active Member

    Joined:
    Apr 7, 2019
    Messages:
    141
    Likes Received:
    155
    Seems like it's just certain shaders that are broken. Anyone else having this problem?

    Screenshot_ks_lotus_72d_ks_brands_hatch_9-11-119-23-49-19.jpg

    Screenshot_ks_lotus_72d_ks_brands_hatch_9-11-119-23-50-24.jpg
     
    MLT likes this.
  10. MLT

    MLT Active Member

    Joined:
    Nov 2, 2017
    Messages:
    136
    Likes Received:
    134
    I've been getting this as well, at first I thought I had something wrong with settings, but it seems the shader has issues.
     
  11. MGMetroDave

    MGMetroDave Active Member

    Joined:
    Apr 7, 2019
    Messages:
    141
    Likes Received:
    155
    @MLT Thanks, glad it's not just me or my settings. I could tell something was wrong when preview245 was released but couldn't initially put my finger on what was wrong. I've let Ilja know about it. Hopefully it'll be fixed soon.
     
    Leonardo Ratafia likes this.
  12. MGMetroDave

    MGMetroDave Active Member

    Joined:
    Apr 7, 2019
    Messages:
    141
    Likes Received:
    155
    Oops...

    Screenshot_ks_abarth500_assetto_corse_riggswater_14-11-119-14-5-4.jpg
     
    ChunkiEgg and Prototype like this.
  13. luchian

    luchian Administrator Staff Member Pilot RLR

    Joined:
    Jun 3, 2014
    Messages:
    2,888
    Likes Received:
    1,385
    :lol:
     
  14. Prototype

    Prototype Well-Known Member

    Joined:
    Dec 24, 2018
    Messages:
    328
    Likes Received:
    587
    Location:
    JHB / SF
    Ha ha. You can feel the love with this project !
    Ill admit I dont spend much time around cows, so not sure if they're as loud over an engine as this one is, but maybe the ambient sounds are a bit too loud? Also the river sound, because it comes in and goes out a little abruptly? All subjective.
    If they were softer it may feel more immersive instead of a novelty? My 5c.
     
    AccAkut, MLT and ChunkiEgg like this.
  15. MGMetroDave

    MGMetroDave Active Member

    Joined:
    Apr 7, 2019
    Messages:
    141
    Likes Received:
    155
    Haha yes you're right everything is a bit too loud and lots of things definitely need tweaking, including what you described with the abrupt fade in and out. Thanks for the feedback. I take it all onboard!
     
  16. Sliderman

    Sliderman New Member

    Joined:
    Jul 23, 2018
    Messages:
    7
    Likes Received:
    4
    Hi @MGMetroDave,
    very nice work you´re doing. All this lovely little details. I enjoyed your movie clip a lot, too.

    First of all: Happy new Year 2020 all the forum members!
    I didn´t wrote here much, but I was glad to learn a lot about modding. Thank you all for that. :)

    I´ve now a little prob implementing an helicopter sound and thought you could maybe explain, how you implemented, for example, the cow sounds?
    I´ve tested with an normal 44.1khz, 16 bit, stereo wav file, but it sounds like a very, very distant plane sound, not an helicopter sound.
    Did you did it yours with fmod? Could you post your settings for the wav file and how to call it in audio_sources.ini?

    Sorry, I don´t want to hijack your thread, but I thought asking you here would be the best, if others struggles with same prob, they can benefit from your explanations, too. :)
     
  17. Stephen Brown

    Stephen Brown New Member

    Joined:
    Sep 3, 2018
    Messages:
    16
    Likes Received:
    8
    Wow, this looks amazing. Totally slipped under my radar too. Love all the little details.
    Looking very much forward to driving it.
    Keep up the great work!
     
  18. xXxKOKExXx

    xXxKOKExXx Member

    Joined:
    Dec 25, 2019
    Messages:
    56
    Likes Received:
    50
    OMG, i feel im a f** nerd seeing that quality of skills :ROFLMAO:
    awesome! this job is f*** awesome!
     
  19. MGMetroDave

    MGMetroDave Active Member

    Joined:
    Apr 7, 2019
    Messages:
    141
    Likes Received:
    155
    @Sliderman ! So sorry for long time to respond. I've not been able to be involved with modding for a few months as Real Life (TM) sadly got in the way ;-) I've just got back to AC for the first time in months and after a little testing, I've noticed that currently audio in tracks seems to be broken. It last worked in CSP 0.1.36 and since then (current version at time of writing is 0.1.40) it's still broken. It seems to have coincided with the adding of the volume slider in the 'Track Adjustments' section of CSP extension settings in CM.
    As I don't know which other tracks currently include any custom sounds, I can't test if it's just my track, but assuming it isn't, if you want to test custom sounds on your track you'll probably need to downgrade temporarily to CSP 0.1.36.

    This next bit might not be completely accurate as it was months ago that I did the sounds and I'm a bit rusty...Regarding sound formats, I don't *think* it's crucial. I'm pretty sure mine were 44.1/16 bit if I recall, and some were stereo and some mono, so both should work. If you're intending on looping the sound seamlessly I *think* it needs to be WAV rather than MP3, but I don't honestly know the optimum settings for memory usage. I'd imagine MP3s get decompressed while the game's running anyway? Not sure sorry.
    I've noticed that sounds trigger as you (the camera, be it inside the car or out or free) get within the range of the sound as specified in fmod, and stop when you're out of range again. If it's a looping sound it loops until you get out of range. That sounds obvious but I've noticed it whenever it triggers it starts again from the start of the sound wave. Might be useful to bear in mind.

    With all that in mind, here are a details about how I used it in my track so far....hope it helps!
    ------

    Firstly, I have the actual sound bank (.bank file) in the following location:

    content\tracks\riggswater\extension\sfx\riggswater.bank

    and alongside it is the GUIDs.txt file. So those 2 files are all that I have in that folder.

    So the following is in GUIDs.txt (content\tracks\riggswater\extension\sfx\GUIDs.txt) (this file is output from FMOD) I can't remember if I tweaked it or not. I don't think so...:

    {dc612bac-455b-473b-b39e-4cea44351f78} event:/common/riggspubmusic2
    {a5c4847f-4b46-4ad6-986d-9391c634b1dc} event:/common/riggspubmusic1
    {9c40411a-491f-4bd0-998c-43699f8e1f03} event:/common/riggscow1
    {29175f54-0ae7-41f2-a3b1-06bb12207e11} event:/common/riggssheep2
    {999089ba-4a6d-4f2a-b0ab-220d0c3d4e96} event:/common/riggssheep1
    {1d42c540-aaf7-4c70-a6d8-bdc11ace4f36} event:/common/riggswaterfall1
    {b47658eb-dc71-4747-a822-e4aeb143f1fd} event:/common/riggswaterfall2
    {3ea3f6d0-aa71-4599-a359-b480d3cccca3} event:/common/riggsbirdsong1
    {43ec6895-9033-48e0-8a9c-17f3b981ffbb} event:/common/riggsbirdsong2
    {4636e4e2-01ed-4bee-b9ff-0efe76794354} event:/common/riggsbirdsong3
    {08dd864f-5be6-44f0-8686-cf4d2ff1c59a} event:/common/riggsbirdsong4
    {60a60edd-dc16-4e0d-a9f4-ff4689ff887e} event:/common/riggsbirdsong5
    {98317912-a380-4e75-a22b-c6a7a9cd4a72} event:/common/riggsducks1
    {914a3a6e-ec99-490a-b7c5-b11d0ba83185} event:/common/riggslake1
    {9e540e7e-0d00-4f61-b953-ee6083f2bfee} event:/common/riggslake2
    {08f6ba78-f576-4f9f-a232-47657d5fec19} bus:/
    {47dcf37a-6a8d-4ef6-9f82-2e0398fa69f9} bank:/common
    {6f849ccf-dfec-43c7-9327-976a1fe7a76a} bank:/riggswater

    Then in my track's ini file, which in my case is content\tracks\riggswater\extension\ext_config.ini, I have, among other settings, got the following....

    [SOUNDBANK_0]
    BANK=sfx/riggswater.bank
    GUIDS=sfx/GUIDs.txt

    [EVENT_0]
    ID=common/riggssheep1
    REVERB_RESPONSE = 1
    POSITION = 1066.84, 78.5656, 716.797
    DIRECTION = 0, 0, 1
    VOLUME = 3.5
    CAMERA_INTERIOR_MULT = 1
    CAMERA_EXTERIOR_MULT = 1
    CAMERA_TRACK_MULT = 1

    [EVENT_1]
    ID=common/riggssheep2
    REVERB_RESPONSE = 1
    POSITION = 1068.93, 77.40, 729.6
    DIRECTION = 0, 0, 1
    VOLUME = 3.5
    CAMERA_INTERIOR_MULT = 1
    CAMERA_EXTERIOR_MULT = 1
    CAMERA_TRACK_MULT = 1

    [EVENT_2]
    ID=common/riggsbirdsong1
    REVERB_RESPONSE = 1
    POSITION = 1042,67,798
    DIRECTION = 0, 0, 1
    VOLUME = 1
    CAMERA_INTERIOR_MULT = 1
    CAMERA_EXTERIOR_MULT = 1
    CAMERA_TRACK_MULT = 1

    [EVENT_3]
    ID=common/riggsbirdsong2
    REVERB_RESPONSE = 1
    POSITION = 1165,86,805
    DIRECTION = 0, 0, 1
    VOLUME = 1
    CAMERA_INTERIOR_MULT = 1
    CAMERA_EXTERIOR_MULT = 1
    CAMERA_TRACK_MULT = 1

    [EVENT_4]
    ID=common/riggswaterfall1
    REVERB_RESPONSE = 1
    POSITION = -271.3,5.2,35
    DIRECTION = 0, 0, 1
    VOLUME = 8
    CAMERA_INTERIOR_MULT = 1
    CAMERA_EXTERIOR_MULT = 1
    CAMERA_TRACK_MULT = 1


    etc....

    I should add that these settings, especially the volume related settings are probably not optimal. They were for testing purposes. I expect that the recommended range is 0 to 1. Perhaps someone can confirm?

    Again I'm a bit rusty on this, so please someone correct me If I'm mistaken but.........

    [EVENT_x] unique event number. I expect you could simply use [EVENT_...] for all of them, but haven't tested it.
    ID= path and audio file in fmod bank, as referenced in the GUIDs.txt
    REVERB_RESPONSE = Is the sound affected by reverb
    POSITION = X,Y,Z is the 3D location in space of the sound. This works the same as if you're adding lights using the x,y,z method, where you can get the position using the shaders patch debug app (https://www.racedepartment.com/downloads/custom-shaders-patch-debug-app-advanced.29060/).
    DIRECTION = X,Y,Z direction as a 3d vector I think??? (cone angle and things I think are specified in fmod when you make the bank)
    VOLUME = general volume of sound
    CAMERA_INTERIOR_MULT = amount to multiply volume level by if using interior car cameras
    CAMERA_EXTERIOR_MULT = amount to multiply volume level by if using exterior (chase) car cameras
    CAMERA_TRACK_MULT= amount to multiply volume level by if when in free camera mode and trackside cameras

    I think that's it! I'm sure I've made some mistakes, but it'll hopefully help a little.:lol:

    Edit: Also, I'm sure you've read it, but more info here: https://github.com/ac-custom-shaders-patch/acc-extension-config/wiki/Tracks-–-Audio
     
    Last edited: Feb 7, 2020
    Sliderman, Won, luchian and 1 other person like this.
  20. Johnr777

    Johnr777 Moderator

    Joined:
    Jul 26, 2017
    Messages:
    539
    Likes Received:
    386
    Told Ilja about the track audio not working and he fixed it in 0.1.42! Turns no one had told him since no one is using this..

    I followed what you wrote and the info from the SDK, was able to get some pit garage sounds, it’s actually pretty easy! Might add more sounds to Mosport :)
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice