QUESTION Race start counted as lap, AI stopping at crash site

Discussion in 'Tracks' started by lilbroomstick, Jul 2, 2020.

  1. lilbroomstick

    lilbroomstick New Member

    Joined:
    Jun 19, 2020
    Messages:
    5
    Likes Received:
    1
    Hi, I am making a kart track that I have been to in real life. I have got the ai working, the red lines (ai boundaries) set up, etc. I started my first race and from my grid spot to the start/finish line counted as a lap, so it says my best time is 6.5 seconds. For example in game it would say lap 2, but it is truly lap 1 because I have not done a full lap yet, I just crossed the line from the starting grid. I think one reason is because I have not put sectors? I don't know. I have considered just putting the starting line behind the grid, but I wanted to keep the original timing line.

    My other question is, if one ai kart crashes, why do they all pile up? I have made 3 different ai lines along with ai boundaries, and every time they crash, they all stop and then retire. So I think it is not the ai line being faulty. Is there any way to change this? I think I heard of something called ai flood for something like this. Other than that, my track is probably done and ready to be released.
    best time.PNG
     
  2. Johnr777

    Johnr777 Moderator

    Joined:
    Jul 26, 2017
    Messages:
    666
    Likes Received:
    446
    Yes, I believe you need at least one sector gate.

    AI flood is for something else entirely. Hard to diagnose your issue without a video or at least some screenshots. Is it a tricky area of the track?
     
    lilbroomstick likes this.
  3. lilbroomstick

    lilbroomstick New Member

    Joined:
    Jun 19, 2020
    Messages:
    5
    Likes Received:
    1
    The AI just stop, I don't know why. It could be anywhere on the track, even at the start as the videos show. At the end of the track there is a quick chicane where the ai wreck, and they pile up there too. I don't have video for this, but they also did all retire at once. I hope this helps.

    Edit - I did another race to see how the timing worked. The ai crashed at one point, grouped up, and mass retired. The video is below, excuse my terrible driving, on controller because I cannot access my wheel right now.
     

    Attached Files:

    Last edited: Jul 2, 2020
  4. Kou

    Kou New Member

    Joined:
    Jul 21, 2021
    Messages:
    1
    Likes Received:
    0
    I just stumbled upon this, while having the same problem (i didn't download the videos). My AI always crashed shortly after the start finish line and just piled up. You have to record at least two ai-line-creating-laps in a row and try to really match the lines and try to not brake and then press "save ai" but to just hit save ai while for example on a long straight and then just exit the game. That solved it for me at least.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice