SOLVED Car is spawning sideways in game???

Discussion in 'Car Models | Physics' started by jayson_p, Sep 1, 2022.

  1. jayson_p

    jayson_p New Member

    Joined:
    Sep 1, 2022
    Messages:
    4
    Likes Received:
    1
    Hey guys, I've just finished up my car model in kseditor and exported to kn5 and booted up the game but for some reason the main body of the car has turned sideways. The car looks fine in 3ds and kseditor but when it gets into game it pings sideways :/ The car seems to handle fine but for obvious reasons it doesn't look right.
    upload_2022-9-1_3-44-29.png
    upload_2022-9-1_3-45-49.png
    upload_2022-9-1_3-44-45.png

    Anyone know what might be causing it? I've tried adjusting the pivot points of the parts and aligning them to world but nothing is having any sort of effect :/
     

    Attached Files:

  2. Fuzo

    Fuzo Member

    Joined:
    May 24, 2018
    Messages:
    56
    Likes Received:
    11
    Location:
    Bydgoszcz, Poland
    every time when some mesh is facing wrong way there can be only one reason, wrong pivot point orientation, nothing else. So your final export has to be exported with correct settings. Y axis up, Z facing to the front. If the mesh is under some node, then pivot point of the node will determine the orientation of the object.
     
  3. jayson_p

    jayson_p New Member

    Joined:
    Sep 1, 2022
    Messages:
    4
    Likes Received:
    1
    I've checked the pivot of the main body of the car and its angled the same as the wheel dummies - Z forwards, Y up and X to the left and my export options are also set to Y up.
    upload_2022-9-2_14-30-14.png
    Is there anything else you think I could have missed?
     
  4. Fuzo

    Fuzo Member

    Joined:
    May 24, 2018
    Messages:
    56
    Likes Received:
    11
    Location:
    Bydgoszcz, Poland
    Are you changing those pivots in view mode or local mode? You need to use local mode. And check all other pivots, they all need to face to same direction.
     
  5. jayson_p

    jayson_p New Member

    Joined:
    Sep 1, 2022
    Messages:
    4
    Likes Received:
    1
    I've just had a look and I'm on local mode. I made sure that all of the pivots are facing the same way but its still not changing anything :/
    upload_2022-9-8_17-0-58.png
     
  6. Fuzo

    Fuzo Member

    Joined:
    May 24, 2018
    Messages:
    56
    Likes Received:
    11
    Location:
    Bydgoszcz, Poland
    Try to create node named VEHICLE_BODY, put it to 0,0,0 coordinates, and put selected stuff from the picture under that node. I personally would ditch those groups, because it can cause problems. If this won't help, contact me on discord (in my signature) and we can troubleshoot it together, I have MAX 23 as well.
     
  7. Fuzo

    Fuzo Member

    Joined:
    May 24, 2018
    Messages:
    56
    Likes Received:
    11
    Location:
    Bydgoszcz, Poland
    just noticed in the picture, your model is not correctly placed in the scene, you should move it all 90 degrees, your Z axis is heading to the left side, you can see it on the cube in the viewport corner :D
     
  8. jayson_p

    jayson_p New Member

    Joined:
    Sep 1, 2022
    Messages:
    4
    Likes Received:
    1
    Ayyy yeah thats done the trick, it was that simple hahaha.
    upload_2022-9-9_21-18-0.png
    Thanks for your help! :)
     
    Fuzo likes this.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice