Landsberg Rallye V.09 2018-08-25

Enjoy the beautiful Green Heart of Germany!

  1. silva

    silva New Member

    Joined:
    Mar 17, 2016
    Messages:
    2
    Likes Received:
    3
    luchian likes this.
  2. luchian

    luchian Administrator Staff Member

    Joined:
    Jun 3, 2014
    Messages:
    1,912
    Likes Received:
    691
    Gave it a try this weekend. Even with the latest microsoft stuff installed, I still had troubles running some layouts (the 1st and the 2nd). And the errors in the log are a bit weird - because it makes it look like the problem is with the car, and not with the track. Which can't be, since I only tried official cars. On 2 ocasions, the PC completely freezed and had to reboot - never happened to me before.

    That being said, when it loads, this is quite nice ! :) Having driven in Bavaria/around, I find it does convey that specific feeling.

    When I'll get some more time, I'll try to have a closer look and maybe spot the issue (unless I am the only one, and the problem is on my PC) :ninja:
     
  3. luchian

    luchian Administrator Staff Member

    Joined:
    Jun 3, 2014
    Messages:
    1,912
    Likes Received:
    691
    Spent a half an hour yesterday evening testing different (usage) scenarios. I mean no disprespect to the amount of work you have probably put into this project. However, my humble opinion is that _something_ was done with little to none optimization. For example:

    The race layout (only one that actually loads for me) uses more than 13GB of Ram ! For comparison, Nordschleife only uses about 3.5 Gb. Also the number of triangles is double. Same goes for the scene.
    There is no reason to have such high numbers - and it is probably what causes the weird behaviour. I had also a quick look at your "How-To" and "Future plans" pages, so here are some possible ideas for improvement :
    - Did you by any change left that HD mesh "as is" for the project ? If yes, it consuming a lot of unuseful tris/memory - you only need high-detail mesh on the actual roads - the rest of the terrain can be very simple geometry without any visual loss (e.g. you don't need hd mesh on the crop fields)
    - Did you maybe used very high resolution textures ? You can get away with 1 or 2, but otherwise make use of the multilayer shaders - visual difference will be minimal to none.
    If none of the above applies, then I can't think at something else at the moment, and do not have time to go more into detail (i.e. actually look into the kn5).

    Just to avoid misunderstandings:
    - I do (alawys) have the latest VS installed because I use it for different stuff; but tbh, I do not see the link between it and a mod track;
    - I am not bashing your work; just giving my honest opinion about it - and I find it a pitty that a nice loking track cannot be enjoyed after all the work that wento into it.

    Good luck, should you plan to optimize this. :)
     
  4. silva

    silva New Member

    Joined:
    Mar 17, 2016
    Messages:
    2
    Likes Received:
    3
    Thanks a lot for your hints. And sorry for the late answer. We are troubleshooting in this racedepartment thread: https://www.racedepartment.com/threads/landsbergrallye-wp1-track-release.129998/
    Did you try to load with the prefix: http://www.mediafire.com/file/z6ktkulsyyc5a8d/landsbergWP1_09_prefix.7z/file
    ?

    Anyway thanks for your help. I am working on tracking down the error. Sadly none of my beta testers was able to reconstruct this 13GB RAM problem yet... The track is supposed to use less than 3GB. The problem is about physical objects. You can read more about it in the racedepartment thread.
    Cheers!
    Silva
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice